1 (edited by MNShortBus 2016-01-17 02:50:03)

Topic: FIS Control Not Working


I have been attempting to get FIS control to work on my 2003 MKIV GTI for the last few hours on my new cluster (not IMMO adapted yet) No matter what I try, or what coding I have placed in the cluster I cannot get the FIS control to display on the FIS screen. Current coding is 16234. I have no Nav installed but the factory Monsoon radio sends station info to the cluster and is displayed at the top.

The Up/Down/Reset buttons on the wiper stalk work when the cluster is directly connected to the car. However, once I install the FIS control adapters and plug in the FIS control, I cannot cycle through the screens anymore. The buttons are completely dead. I have checked the wiring adapters with a multi-meter and all connections are OK.

The FIS is available by bluetooth so I know it is getting power. I attempted to update to the most recent version with the android update app but all it does is connect to the FIS control. I waited over 15 minutes and the status did not change.


At this point I am out of ideas. Nothing works and it looks like I was shipped a bad FIS control box. sad

Suggestions? Any help would be greatly appreciated.

Re: FIS Control Not Working


after turning on the ignition, the FIS-Control tries to communicate with the instrument cluster. If this fails, the FIS-Control is not able to enter its normal operation mode. It will not forward the signals from the wiper stalk buttons to the cluster in this case. So this explains why the buttons are dead.
The reason why the FIS-Control can not contact the cluster is your radio. Let me explain:
Devices can send data to the cluster either by CAN bus or by 3 wire bus. The radio uses CAN bus, the FIS-Control uses 3 wire bus. Some clusters (like yours) give higher priority to the CAN bus. That means that the cluster disables its 3 wire bus interface as soon as it gets the first data from the radio via CAN bus.
This is a problem that I can not solve at the moment. It does not help to turn off the radio, because it is still active on the CAN bus.
So this can only be solved by disconnecting the radio from the CAN bus. But you might lose some functions of the radio this way.

About the problem with the software update. Please make sure, that you press and hold the Reset button on the wiper stalk while turning on the ignition. Pressing the down button also enables the Bluetooth module of the FIS-Control but will not set it into software loading mode.


Re: FIS Control Not Working

Interesting... do you know what clusters do not give higher priority to the can bus? Specific models?

I'm currently swapping over a cluster that was reprogrammed from W8 Passat to a MKIV with a new EEPROM flash. I'm wondering if there is something in the EEPROM that could be changed to prevent the 3 wire bus from being turned off.

Anyways, I'll disconnect the radio from the car and test again.


Re: FIS Control Not Working

I heard of some Passat clusters that give higher priority to the 3-wire-bus.
Do you have the chance to test the W8 cluster with the original EEPROM and with the Mk4 data set?
Maybe you could find out, if the CAN bus priority is an EEPROM settings.

Re: FIS Control Not Working

I'm going to investigate the EEPROM stuff to see if there are some options. I'm pretty limited on knowledge when it comes to that stuff though. I did not have a change to test with the original W8 EEPROM.

Good news though, I did get the FIS Control to work by unplugging the radio and then forcing the can bus controller to re-scan for modules via vag-com. Restarting the cluster then allowed the FIS control to start working. I guess this didn't work the first time because I did not re-scan the can bus with the radio uninstalled. Unfortunately reconnecting the radio immediately disables the FIS Control.

Now I have another question... I want to eventually install a factory VW MFD Nav unit. Will I still be able to use the FIS control with that installed or will I have to remove that device from the can bus system as well?

Thanks again!

Re: FIS Control Not Working


most MFD nav units are using the 3-wire-bus to communicate with the cluster. They are perfectly compatible with the FIS-Control.
Only exception (as far as I know) is the "MFD version G" that uses CAN bus and will cause the same problems as your radio.

7 (edited by ilezh 2016-04-03 13:48:03)

Re: FIS Control Not Working

I just bought used v 1.0 fis-control by zzottel(?). I double checked all the wiring and everything seems to be ok.
Still, same issues as listed here before. Buttons on wiper stalk doesn't work anymore. And the fis-control does not work.
I connected the fis-control to 3-wires from radio, I have audi concert (plus) and no gps.
Any ideas? Is there any update or eeprom I could download to the FIS-control? I tried to connect laptop to fis, but it didn't connect.
I still didn't try to connect to fis-control on table, thats what I'm going to do next.

Also my car Is -01 b5rs4. This fis-control was fitted before in s3 I think.

Re: FIS Control Not Working


here is a collection of information and the latest firmware for the FIS-Control 1.0:

Have you checked the coding of your instrument cluster?
The coding value should be bigger than 16000. If it's not, add 16000 to the current coding.
Additionally you will have to check that the adaptation channel 62 is set to the value "0".