Topic: Bug? Default group selection when changing ECU

Hi Stefan,

It often happens that I want to look at a different control unit while driving. But the last-read group from the previous control unit is used as a start point, which is not predictable.

If I am in Presets and have ECU 01 Group 15 shown, when I select Measurement then FIS-Control will first show me Group 15. This is helpful! When a Collection preset is viewed, on selecting Measurement the group first shown will be one of the ones from the collection (depends which was read last, I guess). Less helpful but still ok.

But, say I then set the Control Unit to AWD (22). When I select Measurement, FIS-Control gives me Group 50 in control unit 22. This is because my AWD unit only has values in groups 01, 02, 50-59, 61-62, 70... and my configuration file has all others masked.

If I switch back to ECU 01, then I get ECU 01 Group get back to Group 15 I have to press the down button a lot!

I think that after changing ECU, the next group shown in Measurement should start from G01.

Car is a Mk4 Golf if that is relevant smile



Re: Bug? Default group selection when changing ECU

Hi Nick, you are right, this is how I implemented it.
I thought about that a while ago. Always starting at G001 is not the best solution. For example if you want to go to group 115 to see your boost again.
I would use the presets to get back to my favorite groups. So for excample if you are in group 50 of the control unit 22 and you want to go back to the engine control unit, I would just select a preset with a measurement from the engine control unit.
If you need the control unit 22 more often, I would also create a preset with it.

Re: Bug? Default group selection when changing ECU

Hi Stefan,

If I've manually changed control unit and then go to Measurements then I always want to go to 01... it's already a lot of button presses.

In a Preset (for me almost always a collection)
Press Set to get main menu
Go to Settings
Go to Control Unit
Select control unit
Back to Settings
Back to Main Menu
Go to Measurement
- displays "Connecting..."
Get some random group number because you don't know which group was last read in the collection

I never want to go from (for example) group 02 in one control unit to group 02 in a different control unit because there are none in my car that are compared like this. Maybe you do this more often in vehicles with CAN connected to the FIS-Control? For me, as each preset can only show values from one control unit I have almost all of them from the ECU to avoid many different connect/disconnect cycles when scrolling through them.

I don't think I understand your example. I agree when switching from preset to measurement that it's useful to go back in the same group, but if I change control unit and then go straight into Measurement I always always want to look from the start of that control unit. If I went in Presets it would change control unit again..?

Yes, I could make a preset of E22/G001 but that only makes it shorter to change control unit. By definition any time I change control unit by hand, it's because I want to check a group I don't check often enough to have as a preset! smile

Another good reason - my ABS controller seems to have a bug where it stops communicating if you ask it for a group outside the range 01-07. I didn't manage to make it work until today so I hadn't set the masks for that unit! This might explain some odd "cannot communicate" bugs as you don't display which group you requested until after communication is established...

Maybe this could be a tweak so users can choose?


Re: Bug? Default group selection when changing ECU

Ok, understood. I think I can improve that.

Re: Bug? Default group selection when changing ECU

Thank you! Sorry if I didn't explain very well.

Re: Bug? Default group selection when changing ECU

Hi, I just uploaded a new firmware.
When you click SETTINGS -> SAVE SETTINGS, the FIS-Control will remember the currently active measurement group.
When you manually select another control unit, the FIS-Control will start with the "stored" group.

7 (edited by nick 2020-12-10 03:37:37)

Re: Bug? Default group selection when changing ECU

Hi Stefan!

Sorry for missing this post, I didn't have notifications turned on...

Thank you for adding this feature. It has solved half of my problem!
I have upgraded to fw 2020-11-22 and tried Settings->Save Settings with my "favourite" groups for each control unit. Now, like you say, if I am in Measurement and then go to Settings->Control Unit, change to a different unit and then select Measurement again, it jumps to the stored Group. This is much more useful! smile The ABS controller doesn't crash any more when the FIS Control tries to connect to it.

However this still does not quite work in my normal use case.
Example: I have Group 002 stored as the "favourite" for my AWD controller on Control Unit 22.
For this Control Unit the mask shows groups 001, 002, 050, 051, 052 [etc].
Most of my Presets are Collections, but I have some single values and Measurements too.
Say I am looking at a Preset which shows a Measurement, E01 Group 031 (fuel-air ratios).
Test 1) If I now enter the menu and select Measurement, I see E01 G 031 - fine, normal, useful. I think this is the most useful behaviour if the Preset is a Measurement.

Test 2) If I instead enter the menu and select Settings->Control Unit->AWD (22), then go back out of Settings and select Measurement, I do not see my stored group G002, but instead the closest available (unmasked) group to G031 which happens to be G050. I think it would be better if this showed the group I stored...

Test 3) Looking at a Preset which is a Collection (six different values all from E01), if I press Reset to get the menu and then choose Measurement, I get a random Group from the six which were used in the collection. I think if you go from a Collection straight to a Measurement it should first show the stored Group, not a random choice from the Collection.

Does that make sense? I can attach my configuration if I didn't explain well. Oder vielleicht könnte ich versuchen, es auf Deutsch erklaren smile

Thank you!


Re: Bug? Default group selection when changing ECU

Hi Nick,

thanks for your detailed feedback.

The FIS-Control does not store a default group for each control unit separately.
But I still do not expect your result for "test 2". If stored group is G002 and you change from engine control unit to AWD control unit, the default group should be loaded.

About test 3. This is expected. The FIS-Control will remember the last group that was used in a preset and will use the same group for the MEASUREMENT. As the collection presets cycles over all needed groups, the "last group" could be any of the used ones. If this is a issue, I could change that behaviour.

9 (edited by nick 2020-12-10 17:16:28)

Re: Bug? Default group selection when changing ECU

Ah! I had misunderstood what you meant by "stored group". I thought this was saving a default group for each different ECU in the new software. I think I get it now, thank you for explaining.

Test 3: Yes, I think it would be better if you always used a consistent "last group" when moving from a Collection to a Measurement. This would take away the random element.

Maybe if you always used the first item in the collection? Then I could order the collections differently to always go directly and quickly to a chosen group, to see the other values in that group which weren't part of the collection.

I have attached my config so you get an idea of how I use it smile

Post's attachments

fis_control (5).dat 64 kb, 1 downloads since 2020-12-10 

You don't have the permssions to download the attachments of this post.

Re: Bug? Default group selection when changing ECU


could you repeat "test 2" and tell me if works as expected?

Re: Bug? Default group selection when changing ECU

Hi Stefan,

See this short video. Before the video started I selected E01 G050 and did Save Settings, then exited to BC.

- Opened FIS Control menu by long-press of Up key
- Selected Measurement: got E01 G050
- Did Settings/Save Settings again (just to show it happened)
- Back to Measurement and selected G051 to see if I got the current group or the saved group
- Changed Control Unit to AWD (22), opened Measurement: got group 001. I was expecting either 050 or 051.
- Selected E22 G051
- Changed control unit to Engine (01), opened Measurement: got group 001. Again I was expecting 050 or 051.

Does this help? Maybe I still don't quite understand.


Re: Bug? Default group selection when changing ECU

I think the reason is, that the FIS-Control reads the settings file only during startup.
Please save your default group. Then turn the ignition off.
Check if it works as expected next time you start the FIS-Control.