1

(18 replies, posted in Allgemeine Diskussion)

Hier im Audi 4G (pre facelift):
https://fis-control.de/images/20190611_182929.jpg

Hi Chris,

liegt vermutlich an der Codierung vom Tacho. Hast du den Anpassungskanal 62 auf den Wert "15" gesetzt?

Ginge höchstens beim Facelift, bei dem Geschwindigkeit und Drehzah über den CAN-Bus übertragen wird.

Manche Tachos können nur Großbuchstaben anzeigen. Probier mal ob es daran liegt.

5

(18 replies, posted in Allgemeine Diskussion)

Hier im Audi RS6 (4G Facelift):
https://fis-control.de/images/rg-racing.jpg

6

(49 replies, posted in Allgemeine Diskussion)

Hi,

an welchem Sensoreingang hast du LTex hängen?
Du kannst unter EINSTELLUNGEN -> SENSOREN für den entsprechenden Sensoreingang mal "ADC SPANNUNG" auswählen.
Dann zeigt dir als Messwerte die Spannung angezeigt, die das FIS-Control an diesem Eingang misst.

Warum die Einheit vom Ladedruck sich ändert, muss ich im Code mal nachschauen.
Prinzipiell ist es so, dass man unter EINSTELLUNGEN -> LADEDRUCK ein Steuergerät und einen Messwertblock auswählen muss. Sind in diesem Messwertblock irgendwelche Drücke, werden sie in die gewünschte Einheit (mbar, bar psi) umgerechnet und bei relativer Skala noch der Umgebungsdruck abgezogen.

7

(70 replies, posted in Allgemeine Diskussion)

Super. Erscheint auch die Anzeige vom RNS-E noch, wenn man die Zündung mit gedrückter Hochtaste einschaltet?

8

(70 replies, posted in Allgemeine Diskussion)

Hi, die "Hrdina" und "Motorstart" widersprechen sich. Für den Nutzer "Hrdina" hatte ich eingebaut, dass das FIS-Control direkt beim Einschalten der Zündung den "Preset 1" öffnet. Über "Motorstart" öffnet sich der Preset nach Anlassen des Motors.

9

(13 replies, posted in English forum)

I think I can add support for the steering wheel control.
And yes, it is possible to have the FIS-Control automatically active either when turning on the ignition or when starting the engine.

For start on ignition:
- Enable SETTINGS -> USER MODS -> HRDINA

For start with engine:
- Enable SETTINGS -> USER MODS -> RPM CAN
- Enable SETTINGS -> AUTOSTART -> ENGINE

10

(7 replies, posted in Probleme / Wünsche / Verbesserungsvorschläge)

Das Radio reagiert wohl nur dann auf die MuFu-Tasten, wenn es auch auf dem Tacho-Display zu sehen ist.
Ist dort stattdessen das Telefon (bzw. das FIS-Control) zu sehen, ignoriert es die Tasten.
Das ist in soweit gewünschtes Verhalten, da bei aktivem Telefon ja nicht die Radiolautstärke, sondern die Telefonlautstärke gesteuert werden soll.
Den Workaround (Titelzeile auf "Radio" stellen) habt ihr ja schon gefunden. Eine bessere Lösung fällt mir leider nicht ein.

11

(13 replies, posted in English forum)

As you have installed a radio and also phone, the upper part of the screen is already occupied and not usable by the FIS-Control.
To avoid the flickerung, go to SETTINGS -> HEADLINE and select RADIO.

Are the steering wheel button free to use, or do they also control other stuff? I could make the FIS-Control respond to the buttons, but I can not prevent the buttons from doing their intended functions.

12

(13 replies, posted in English forum)

Adoption value "15" is correct.

13

(13 replies, posted in English forum)

Ok, now you just need to set the correct coding for the FIS-Control and the cluster:
- Press and hold the down button at the side of the wiper stalk and tunr on the ignition.
- Connect the FIS-Control app to the FIS-Control
- Select "Firmware version" and click SEND
-> You should see the date of the current firmware in the text field of the app
- Select "Cluster: CAN Telematics" and click SEND
- Select "FIS-Control: Telematics / 3LB" and click SEND.

Now restart the ignition (without holding any button). FIS-Control should appear now, when you do a long press (about 2 seconds) on the up key.

14

(13 replies, posted in English forum)

Maybe the FIS-Control is stuck in software loading mode. Could you please connect the Android app (that is available in the Download section of my website) to the FIS-Control. If you see the letter C arriving once per second in the text field of the app, the FIS-Control is in software loading mode.
In order to make it operational again, you first have to send a valid firmware file.

15

(70 replies, posted in Allgemeine Diskussion)

Nein, LIN-Bus brauchst du nicht anschließen.

16

(70 replies, posted in Allgemeine Diskussion)

Ok, die CAN-Bridge kann ich dir schicken. Aber um die Verkabelung musst du dich selbst kümmern.
Die CAN-Bridge hat eine 9-polige Sub-D-Buchse, wie man auf dem Bild hier im Thread sieht: https://fis-control.de/punBB/viewtopic.php?id=96

Die Steckerbelegung habe ich gerade im Thread gepostet: https://fis-control.de/punBB/viewtopic. … 3348#p3348

Du müsstest nur Stromversorgung und CAN-Bus anschließen. Der CAN-Bus vom Navi muss aber aufgetrennt werden. Wenn du das zerstörungsfrei machen willst, kannst du dafür ein Quadlock-Verlängerungskabel nehmen:
https://www.ebay.de/itm/252087021279

17

(37 replies, posted in OBD, Tuning, Autos, Sonstiges)

Hier die Steckerbelegung der CAN-Bridge:
Pin 1 = Dauerplus 12V (Klemme 30)
Pin 2 = CAN (low) zum Navi
Pin 3 = CAN (low) zum Tacho
Pin 4 = kommt an Pin 3 (TxD) der RS-232 (für Softwareupdate)
Pin 5 = kommt an Pin 2 (RxD) der RS-232 (für Softwareupdate)
Pin 6 = Masse und Pin 5 (GND) der RS-232 (für Softwareupdate)
Pin 7 = CAN (high) zum Navi
Pin 8 = CAN (high) zum Tacho
Pin 9 = LIN-Bus für MuFu

18

(70 replies, posted in Allgemeine Diskussion)

Ich habe noch zwei CAN-Bridges da. Ich könnte dir testweise eine schicken, Dann kannst du ausprobieren, ob es so funktioniert wie du es dir vorstellst.

19

(23 replies, posted in Allgemeine Diskussion)

Hi Holger. Es gibt eine neue Firmware. Dort kannst du unter EINSTELLUNGEN -> MODIFIKATIONEN den Punkt BATTERIE aktivieren und speichern. Wie bei allen Modifikationen wird sie erst ab dem nächsten einschalten der Zündung aktiv.

Die Batteriespannung wird dann mit einer Nachkommastelle angezeigt und statt des Ladedruck-Symbols wird ein Batterie-Symbol angezeigt.

20

(61 replies, posted in Allgemeine Diskussion)

Hi Marco,

die Mouse müsste funktionieren. Aber ob sie standardmäßig schon im richtigen Protokoll und Takt sendet kann ich so nicht sagen. Da scheint ja der uBlox 8030 Chip drauf zu sein. Auf der Webseite von denen finde ich ein ziemlich fettes Dokument zur Konfiguration:
https://www.u-blox.com/de/product/ubx-m … -resources

21

(23 replies, posted in Allgemeine Diskussion)

Ja, kann ich noch schöner machen. Gib mir aber ein paar Tage Zeit.

22

(70 replies, posted in Allgemeine Diskussion)

Die CAN-Bridge wird zwischen die CAN-Leitung zum Navi geschaltet. Bis auf die CAN-Botschaften für den mittleren Anzeigebereich des Tachodisplays lässt sie alle Botschaften unverändert durch. Daher wird auch die Titelanzeige funktionieren.
Bei den Botschaften für den mittleren Tachobereich ändert die CAN-Bridge die sogenannte CAN-ID. Damit gehen diese Botschaften eigentlich ins Leere.
Bei FIS-Control kann man beim Einschalten zwischen zwei Modi wählen. Standardmäßig ist das FIS-Control in seinem normalen Modus und würde so funktionieren, wie du das bereits mit abgeklemmten Navi gesehen hast.
Hält man beim  Einschalten der Zündung die Hochtaste (seitlich am Wischerhebel) gedrückt, startet das FIS-Control in einem Modus bei dem es die CAN-ID von den Navi-Botschaften wieder zurückübersetzt. Dadurch funktioniert dann auch wieder die normale Navi-Anzeige im Tacho, allerdings ist dann das FIS-Control nicht aufrufbar. Man muss sich also nei Einschalten der Zündung entscheiden, ob man die Navi-Anzeige oder die FIS-Control-Anzeige haben will.

23

(70 replies, posted in Allgemeine Diskussion)

Habe heute etwas getestet. Habe allerdings nur ein BNS 5-Navi bei mir am Platz, kein RNS-E.
Am besten funktioniert es, wenn ich die Navi-DVD entnehme und das Navi "NO NAV-DVD" auf dem Tacho anzeigt.
Ich kann das FIS-Control dann immer aufrufen und auch wenn es von einer Warnmeldung verdrängt wird, kommt es danach wieder.

Hi, es gibt eine neue Firmware. Dort gibt es unter EINSTELLUNGEN -> MODIFIKATIONEN die neue Option "Speed Relay".
Wenn diese Funktion aktiviert ist, wird die CAN-Botschaft für die Fahrzeuggeschwindigkeit im A3 8P und TT 8J ausgewertet und abhängig davon die vier Relaisausgänge des FIS-Controls geschaltet.
Die Schaltschwellen kann man unter EINSTELLUNGEN -> SKALA einstellen. Wobei Skala 1 für Relais 1 gilt usw.
Wird die dort eingestellte "obere Linie" erreicht, wird das Relais eingeschaltet, bei Erreichen der "unteren Linie" wird das Relais wieder ausgeschaltet.

Hat man z.B. eine Klappensteuerung an Relais 1 angeschlossen, die ab 60 km/h aufgehen soll und bei Unterschreiten von 50 km/h wieder zu gehen soll, stellt man ein:

EINSTELLUNGEN -> SKALA -> SKALA 1:
OBERE LINIE: +000060.000
UNTERE LINIE: +000050.000

25

(23 replies, posted in Allgemeine Diskussion)

Hi Holger,

es gibt eine neue Firmware. Die Batteriespannung sollte jetzt korrekt angezeigt werden.