Ja, ist das "alte" Discover Pro mit echten Lautstärkeregler
und Auswahlknopf (also zwei Encoder).

Ich muß eh das Klimateil tauschen. Da könnte man den
Test in einem Aufwasch machen. Ich hab das Auto erst
seit ein paar Tagen, aber ich denke (wenn es Dir auch
passt) können wir es ab der letzten Augustwoche mal
in Angriff nehmen.

Scan vom M-Stg können wir ja dann auch bei Dir
machen.

Moje Stefan,

  Hast Du Interesse die FIS MMI mal an einem Passat B8 R-Line
Mj2016 zu versuchen? Der Bildschirm vom Discover Pro wird
ja ebenfalls über LVDS angesteuert smile)) M-Stg läuft über UDS

Hallo Michael,

excallibur wrote:

sollte Interesse an meinem (Michael´s A1 quattro) Hintergrund + Zeiger bestehen, einfach mailen.

Ich würde da mal ganz frech mein Interesse bekunden smile

4

(2 replies, posted in Allgemeine Diskussion)

Moin Stefan,

Merci, daß Du jetzt ein Changelog führst!! smile

Moin,

Sorry für die späte Antwort:

Glückskeks wrote:

Hallo Lightningman,
verstehe ich diesen Umbau richtig, dass Du die Tiptronic-Tasten in Deiner Endausbaustufe vom Lenkrad direkt (über den Schleifring) an die PINs C5/C6 von Stefans FIS-C gehängt hast?

Grundsätzlich: ja. ABER, Es kommt auf das Lenkrad an.
Wenn Du ein reines TT Lenkrad (also ohne MuFu) nimmt,
dann geht das einfach so. Beim MuFu werden alle Tasten
(also auch die TT) vom Stg überwacht. Da kannst Du
nicht einfach eine Taste "abklemmen" und anderweitig
verschalten / nutzen. Du mußt das Stg überlisten, so
daß es glaubt alle Tasten seien noch angeschlossen
(aber halt unbetätigt). Machst Du das nicht funzt es
nicht, weil das Stg sagt es hat einen Defekt. Nach dem
Täuschmod kannst Du dann eine Taste rein elektrisch
(also ohne Stg) über die extra Pins im Schleifring
laufen lassen. Die Masse zwackst Du Dir oben ab und
den + sowie - "Schaltkontakt" legst Du über den
Schleifring nach unten.



Glückskeks wrote:

Ich gehe z.Zt. davon aus, dass diese Schaltanforderungen normalerweise per (CAN?)-Bus an das Getriebe gesendet werden. Hattest Du auch schon überlegt, diese Bussignale an geeigneter Stelle einfach zu entschlüsseln/verwenden?

Die Tasten im MuFu werden alle über das Stg IM Lenkradkranz
(NICHT das 4B0 907 487!! in der Zentralelektrik) zusammengefast
und von dort aus über einen (Eindraht) LIN Bus zur Zentralektrik
ins MuFu Stg geleitet.

Gang rauf / Gang runter sind zwei (digitale) Ausgänge am MuFu**
Stg. Diese gehen dann direkt an das Stg des Automatikgetriebe.
Beim 4B läuft da noch nix über CAN. Da ich einen 6 Gang Schalter
habe, sind diese Signale für meine Verwendung übrig gewesen smile


** = hängt vom MuFu Stg ab. Es gibt etliche Varianten
und diese dann mit oder ohne Ausgänge für die
TipTronic. Ich meine es wäre mit Endung "F", müßte aber
nachschauen um 100% sicher zu sein.


P.S: wegen Deiner PN Nachricht: Das verwechselst Du mich glaube
mit jemand anderem. Ich habe leistungstechnisch (per Chip oder
Kennfeld optimierung) nix am BDG gemacht. Nur WAES. Zum Chippen
bin ich nicht mehr gekommen wink).

6

(1 replies, posted in Allgemeine Diskussion)

Moin Stefan,

Stehst Du mit GoDiesel in Verbindung bzw. haben
die von Dir ein FIS MMI bekommen?. Siehe Bild
hier:

https://www.auto-medienportal.net/artikel/detail/46224

7

(5 replies, posted in Allgemeine Diskussion)

Kratzi wrote:

Hallo,

also bis jetzt benutzt ich die App Torque Pro. Diese App läuft über OBD und zeigt auch den Verbrauch an.

Gruß
Kratzi

Aber nur den Momentanverbrauch smile Die anderen
BordComputer Werte werden im KI errechnet und
sind keine OBD Werte (und somit nicht von Aussen
abrufbar). Die Kurzzeitwerte gehen sogar nach 2
Stunden flöten.

stefan@fis-control wrote:

Nein, geht nicht.

Hä? In dem Bild von oben ist doch gar keine
Drehzahl zu sehen ????. Das ist höchstens
links ein Teil vom Drehzahlmesser zu sehen
und den >könnte< man schon ausbauen .... ;ö))

Mal abgesehen davon ist im Bild nur der normale
Bordcomputer zu sehen (nix FIS Control). Falsches
Bild angeheftet?

Die RFK für den A6_4G alleine reicht nicht aus. Du
brauchst auch das RFK Stg dazu.

> Ich habe das MMI Plus Touch eingebaut

Was war vorher drin?

>Hierzu habe ich im Steuergerät 5F einen Wert geändert.

Welchen? VCDS Scan vorher / nachher?

>Seit dem geht mein Navi und die Audioauswahl im FIS nicht mehr.

Sind die Reiter überhaupt vorhanden? Sonst hast Du im hidden menu
bzw. mit Deiner Codieränderung die beiden Reiter plattgemacht.
Man kann im Green Menu die einzelnen Reiter wegschalten.

> Ich habe die Codierung Rückgängig gemacht jedoch geht es
> immer noch nicht und es zeigt mir weiterhin an das es falsch codiert ist.

Klar, wenn Du die RFK drin hast und sie nicht codiert ist,
meckert Dein 5F weil eben falsch codiert. Zieh die RFK am
MMI Eingang ab und probier es nochmal.

Was hat das jetzt mit Stefans FIS Control zu
tun? (die nebenbei gar nicht im A6 4G
lauffähig ist)

Hmm. Geht das "on-the-fly"? Bei den Atmel Prozessoren
kann man im laufenden Betrieb die Art des Sleepmodus
verändern. Geht das hier auch (ARM Prozessor?)? Dann
könntest Du es doch konfigurierbar machen.

Damit (= zusammen mit dem CAN Bus den "Tag" beginnen
und enden zu lassen) wären auch Probleme wie den von
Dippy (LVDS Line - Open Circuit -Meldung im 5F)
verschwunden, da die LVDS bis CAN Busruhe an bleiben
würde.

Was (welche Überlegung) hat Dich letztendlich davon
abgehalten die Stromversorgung mit Dauerplus zu
machen? Deine Variante würde allerdings eine Fehlbedienung
(aus versehen in die FIS-MMI zu wechseln) bei Screen aus
(oder down) nicht verhindern.

12

(19 replies, posted in Allgemeine Diskussion)

Gefällt mir. Vor allem mit den farbigen Unterteilungen.

Haiola Stefan,

Du schreibst auf Deiner FIS MMI Homepage folgenden Satz:

" Nach Einbau des FIS-Control MMI bleibt das MMI-Display bei
ausgeschalteter Zündung immer ausgeschaltet."

Soll das:

a.) heißen das Display fährt nicht mehr aus (und zeigt nix an)?
Kann ich mir eher schlecht vorstellen, da zum Besten meines
Wissens der Auf/Zu Befehl vom Stg im Mitteltunnel (entweder
E380 oder Touchpad J929) oder dem Taster (aber wieder über
E380 / J929) im Amaturenbrett kommt.

b.) oder heißt daß, das Display zwar auf / zu fährt aber
schlichtweg nix anzeigt, weil die LVDS Transceiver der FIS
MMI keinen Saft bekommen (da dann keine Kl.15 vorhanden)
und somit das Videosignal einfach nicht weiterleiten.

Bei "b" hätte ich einen einfachen Lösungsvorschlag

==> Bistabiles Relais (mit Umpolung!!) einfach parallel
zum Displaymotor (V301) und über die Arbeitskontakte
die Spannung zum FIS MMI Steuern.

==> Kl.30 =>Sicherung 2A =>Bistabiles Relais (COM)
Bistabiles Relais (NO) ==> Power Input FIS MMI.

Sobald das Display ausfährt, schaltet das BiR den Strom
ein (Zündungszustand egal) und sobald der Monitor
einfährt wird der Saft vom FIS MMI gekappt. Damit
kann man dann auch während der Fahrt UND
eingefahrenem MMI niemals aus versehen die FIS
bedienen. Das MMI bleibt ja weiterhin über das
KI und den Lenkradtasten (etc) bedienbar. Da der
Motor immer nur kurz angesteuert wird (bis halt die
Endschalter die Position registrieren), paßt ein
umpolbares BiR (BiR mögen halt keinen Dauersaft)
hier wunderbar ins Konzept.

1-2x Nachteil:

- 1. Geht definitiv nur bei fahrbarem Display ;ö)
- 2. Evtl könnten im MMI Fehler abgelegt werden, wenn
das Display trotz Zündung an kein Videosignal erhält (auch
wenn eingefahren). Das müßte ich testen.

Beim Punkt zwei kann man aber dann mit 2x 1N5407
Dioden Abhilfe schaffen (kleines ODER Gatter für Kl30
und Kl15 bauen.

14

(7 replies, posted in English forum)

Hello,

stefan@fis-control wrote:

I don't know how your headunit tries to detect an open circuit.
The FIS-Control MMI uses decoupling capacitors in the LVDS lines. For DC current a capacitor looks like an open circuit.

Stefan are you using DEcoupling (cap on signal
to ground) capacitors in the LVDS lines or are you
using COupling (in series with the signal line)
capacitors? I suspect the latter since you you
don't want to burden a digital video line with
extra capacitance (slows switching times AND
deforms the orginal signal form).

Either way, however, a capacitor will act as a dead
short when applying DC to it. At least until the
charge on the capacitor plates has been equalized.
After that it looks like an open circuit until charge
on the plates is no longer equal. This is why you
can use a capacitor as a resistor in AC circuits.

However, I don't think that the ECU is this quick
(cap charge time) in filing a fault code.

I think the ECU simply monitors the current that
the LVDS driver circuit is taking up. If it is too
low than it says open circuit. If it is too high it
says short.

As to Dippy's question: I would suggest checking
the four HSD plugs involved (Naviceiver to FC MMI
and FC MMI to Monitor MMI), Maybe one of the
interlocks did not snap in correctly and this is why
you get an open circuit once in a while. If your are
really out of luck it might be that one of the
four pins (in each HSD so a total of 16 fault
possiblities big_smile ) isn't crimped correctly. This would
mean cutting the plug off and putting a new one
on. I absolutely detest even actually execrate
crimping. It is fast, but a real man's connection is
done using solder and a hot iron big_smile

Die Frage ist ja welches FIS ist gemeint?

Falls FIS Control, dann nein und falsches
Unterforum.

Falls FIS Control MMI:Es müßte doch möglich
sein, ein MMI Display an den LVDS Port des
FC MMI zu hängen.

Nur wird es nix anzeigen, da ich mal bezweife
daß beim Fzg von CQ20VT schon das UDS Protokoll
(bzw KWP 2000) werkelt UND selbst falls doch,
dann ist immer noch keine ECU Datei dafür
vorhanden.

Moin Jungs,

Wie nahe an 12V müssen wir den dran
sein, damit die FIS meint der Motor wäre
an?. Nicht daß einfach eine von den Dioden
in der Lima dabei ist sich zu verabschieden
und die FIS meint Motor ist an.

Hallo Stefan,

stefan@fis-control wrote:

Zum MMI: Ob sich eine weitere Hardwareversion lohnt entscheidet die Nachfrage. Aber kurzfrisitg denke ich auch, ist ein Adapter "High-to-Low-Speed-CAN" die bessere Lösung.

Kannst Du schon sagen, ab wann die A6_4G Fahrer
hoffen dürfen? ;o)) Würde natürlich auch gerne
irgendwann meine Rücksitzbank wieder einbauen
wollen (Insider ,o))

Hallo Stefan,

stefan@fis-control wrote:

Wenn ich irgendwie über den CAN-Bus erkennen kann, dass das MMI gerade bedient wird, könnte ich aber wie von Eddy vorgeschlagen das FIS-Control für ein paar Sekunden automatisch ausblenden.

Wie wärs mit dem Hauptencoderrad (1-2 Clicks links
oder rechts)? Oder für die Touchies unter uns: 2x aufs
Touchpad tippen. Man müßte halt schauen, ob das eine
CAN Bus Botschaft erzeugt.....

19

(19 replies, posted in Allgemeine Diskussion)

stefan@fis-control wrote:

Wenn du von einer Anzeige im Tacho-Display sprichst.. die gibt es mit dem FIS-Control MMI nicht.


Hmmm, wäre aber schon eine interessante Idee.......    smile

Hai Stefan,

stefan@fis-control wrote:

Hallo Leute,

Also, wenn ihr Interesse habt, als einer der ersten ein FIS-Control in eurem Audi zu verbauen, meldet euch. Entweder hier im Forum, oder per eMail.


Interesse, ja definitiv, aber Du willst ja (noch) nicht ;ö)). Nein, im
Ernst, beim App, wenn schon ein FIS Control Updater App installiert
ist, kann man das Neue nicht "drüberbüggeln". Die App fragt zwar,
aber wenn man ja sagt, bricht das Programm ab mit der Meldung,
daß es nicht upgedated wurde.

Zur FC MMI: Konntest Du Dir schon überlegen, wie es bei Autos mit
"modernem" Diagnose Gateway laufen soll? Wirst Du eine zweite
Variante der FIS rausbringen oder wirst Du bei der jetzigen Hardware
bleiben und mittels Low-Speed <-> High Speed Übersetzer arbeiten
(getrennte Box)? Ich denke die zweite Variante wäre wahrscheinlich
die bessere.

Für unsere anderen Mitleser: Stefan und ich haben uns vor einiger
Zeit getroffen um das FC MMI an meinem Audi A6 4G zu testen. Da
haben wir festgestellt, daß im A6/4G (und zu 99.799% wahrscheinlich
auch im A7) sowie im A8/4H das J533 (Diagnose Interface) bei allen
CAN Transceivern nur noch die High-Speed Variante vorhanden ist.
Das ist halt insofern blöd, weil Stefan in der FC MMI einen Low Speed
Transceiver verbaut hat... Zusätlich dazu sitzt das Steuergerät nicht
in der Nähe des FC MMi (Beim A6/4G sitzt es unter der Rücksitzbank
und beim A8 im Kofferraum).

Hi,

Turbojochen wrote:

Allerdings kann keine Verbindung zu den Steuergeräten aufgebaut werden.

Hast Du auch nichts anderes an der K-Line hängen?
Das geht nämlich nicht, da die K-Line nicht multifähig
ist. Also VCDS oder sonst etwas darf nicht gleichzeit
mit der K oder L Line verbunden sein. Das Motor-STG
(01 ohne Stern) solltest Du mit Zündung an, bei Fzg
Stillstand und Motor aus eigentlich immer erreichen
können. Genauso wie das KI (also STG 17)

Hmm,

Wäre es dann nicht einfacher, dem BNS die Klemme
15 per Schalter vorne im Cockpit zu entziehen? Sprich
zwischen der Klemme 15 und dem "power up" Eingang
des BNS einen Schalter einzufügen. Ohne Klemme
15 dürfte es auch keine (bzw. Versuch der) Kommunikation
zwischen KI und BNS zustande kommen. Evtl. gibt es einen
Fehlereintrag im KI, weil das BNS nicht auf eine Anfrage
reagiert.

Die No-CD Meldung müßte damit auch weg (da es
nicht mitbekommt, daß nur es keinen Saft von Klemme
15 bekommt) sein. Das ein "toter" Teilnehmer am Bus
hängt dürfte auch nicht weiter stören, da in Falle eines
defekten BNS der Rest des Fzgs. trotzdem weiter
funzen muß.

Dürfte User freundlicher und schneller sein, als die
Methode "Boot-Mode erzwingen" Vor allem, wenn man
mal "schnell" das Navisystem benötigt.

P.S: Ich kenne das BNS nicht so genau und bin jetzt davon
ausgegangen, daß es das System ist, wo der Navirechner
getrennt vom Headunit ist. Falls ich damit falsch liege,
geht es natürlich mit dem Klemme 15 Zwischenschalter
nicht.....

Hallo Michael,

MichaelK wrote:

Hallo Stefan,
- NAV-CD raus aus dem BNS
- über das gleichzeitige lange Drücken der Setup- und Return-Taste  am Radio in das Service-Menü schalten, hier dann den Menüpunkt "Reset" das Radio zurücksetzen
- Die Navigation ist jetzt quasi im Boot-Modus  und benötigt eine Original NAV-CD um wieder aktiv zu werden, also ab jetzt keine NAV-CD mehr einlegen !
Gruß Michael


Bedeutet daß aber nicht auch gleichzeitig, daß man kein Navi mehr hat?
(also schon noch physikalisch drin, aber eben nicht nutzbar).

24

(2 replies, posted in Allgemeine Diskussion)

Hallo WallyE,

Du darfst nicht vergessen, daß die FIS Control nur
"High Level" Abfragen macht (also so wie jeder
Diagnosetester auch). D.h. alleine durch die
Abfrageart kann man die Kommunikation nicht
empfindlich stören. Der CAN Bus z.B. funktioniert
trotzdem, auch wenn CAN High oder CAN Low
nicht mehr funktioniert (die Sende / Empfangsbausteine
können sich auch über nur eine Leitung unterhalten).
Das ist hardwareseitig gelöst und wird auch darüber
(on Chip) überwacht bzw. gesteuert. Selbst wenn
das Steuergerät zerstört wird, bleibt die restliche
Kommunikation auf dem Bus erhalten, da sich die
Transceiver vom Bus abkoppeln, wenn sie zu viele
Störungen verursachen.

Die Systeme sind automotive tauglich. D.h. hier
müssen die Stg, Bauteile, Software, etc besonders
harte Umgebungsbedingungen bestehen können,
um überhaupt die Zulassung zur Verwendung in einem
KFZ zu erhalten.

Die Stg schützen sich selber vor zu hoher Anfrage indem
sie niedrigpriorisierte Anfragen einfach ignorieren. Beim
M-Stg kann man so etwas sehr schön sehen in dem man
einfach versucht zwischen 2 Presets (die beide MWB im
M-Stg abfragen) hin und her zu schalten. Bei normaler
Geschwindigkeit geht das problemlos. Bei hoher
Autobahngeschwindigkeit funzt daß nicht mehr. Da bekommt
man irgendwann einen OBD Comm Error, weil das M-Stg
frecherweise ;ö)) schlicht nicht antwortet.

Anderes sähe daß aus, wenn man direkt an der CPU
des M-Stg abgreifen würde, weil hier die Laufzeit des
"Programms" (viele Stg bestehen nur aus Look-Up Tabellen)
eventuell verändert werden würde (wenn ich z.B. mittels
Interruptauslösung eine Anzwort von der CPU erzwinge).

Die FIS Control hat außerdem einige Hardwareeingänge,
wo man (externe) Sensoren anschliessen kann. Diese (und
auch die Abfrage dazu) greifen überhaupt nicht ins Auto
ein. Dafür kannst Du Dir aber die Werte trotzdem im KI
anzeigen lassen. Vielleicht ist daß die Lösung für Dich?

Evtl. eine schlechte / korrodierte Verbindung irgendwo?